Customer Portal Inbox
Incident Report for Cordero
Resolved
This incident has been resolved.
Posted Aug 17, 2022 - 09:49 BST
Investigating
We have received reports that customers have received an error message when clicking in their inbox. We are currently investigating the issue and will update you once corrected.
Posted Aug 17, 2022 - 09:41 BST
This incident affected: Customer Portal.