Outlook Integration Issues
Incident Report for Cordero
Resolved
This incident has been resolved.
Posted Jun 07, 2023 - 11:40 BST
Investigating
Please, avoid sending emails through outlook until further notice. Any emails sent since last night may have been sent via the portal and not Outlook. We are currently investigating the issue, and will advise once it has been fixed.
Posted Jun 07, 2023 - 09:36 BST
This incident affected: Cordero Application.