Customer portal connection issues
Incident Report for Cordero
Resolved
This incident has been resolved.
Posted Jun 06, 2023 - 15:48 BST
Investigating
We are currently investigating an issue with the customer portal messages.
Posted Jun 06, 2023 - 14:06 BST
This incident affected: Customer Portal.